B9Create 2.0 

Microsoft Visual C++ Redistributables 

 

B9Create 2.0 requires two versions of the Microsoft Visual C++ Redistributable: 2010 and 2015-2019. 

Most computers may already have these tools installed, since many applications depend on them. When B9Create 2.0 is being installed, it attempts to install the redistributables. If for some reason they fail to install, the customer must manually install them in order to run B9Create 2.0. 

The installers for the redistributables should exist on the customer’s computer wherever they installed B9Create 2.0. They also can be downloaded from B9Creations’s server. 

2010 Redistributable 

 

 

Customer’scomputer 

 

 

C:\Program Files (x86)\B9Create2\vcredist_x64.exe 

 

Download 

 

2015-2019 Redistributable 

 

 

Customer’scomputer 

 

 

C:\Program Files (x86)\B9Create2\vc_redist.x64.exe 

 

Download 

 

A popup saying “VCRUNTIME140_1.dll was not found” appears when trying to launch the application. 

Ask the customer to download and run this installer for the 2015-2019 redistributable. 

The Printer Type dropdown is empty and the log file contains “Supports SSL: false” 

There are multiple reasons the Printer Type dropdown could be empty, like if the customer’s license does not have any printers enabled. 

To determine if installing the 2010 redistributable will fix an empty printer dropdown: 

  1. Ask the customer to send you the most recent log file from C:\Users\USERNAME\AppData\Local\B9Creations\B9Create 2.0\logs. The log file will be named something like log_2021-08-17_09-56-52-612.b9log. 

  1. Once you have the customer’s log file, open it in a text editor like Notepad. 

  1. Scroll to the bottom and search for “Supports SSL”. 

If the value of Supports SSL is false, ask the customer to download and run this installer for the 2010 redistributable. 

When the customer tries to install the redistributable manually, it fails to install. 

Sometimes these redistributables fail to install because the customer already has a different version of the same year B9Create 2.0 is attempting to install. For example, the customer may have 2015-2019 version 14.27.28123 when B9Create 2.0 is trying to install 2015-2019 version 14.27.29016. 

In this case, the customer needs to uninstall their existing version before installing B9Create 2.0’s version. To do this, they must: 

  1. Search Windows for “Add or remove programs”. 

  1. Search the program list there for “redist”. 

  1. Find the year for the installer that is failing, like 2015-2019 or 2010. 

  1. Click on their existing version and choose “Uninstall”. 

Once the uninstallation is complete, they should be able to run the installer you have provided them.